コンテンツへスキップ
英語
  • 検索フィールドが空欄のため、候補は表示されません。.

エラー e0094: OpenGL を初期化できませんでした。 - PIX4Dmapper

エラー

エラー e0094:

OpenGL を初期化できませんでした。グラフィックカードの最新ドライバがインストールされていることを確認し、リモートデスクトップからアプリケーションを使用していないことを確認してください。

説明

rayCloudを開こうとすると、上記のエラーメッセージが表示され、rayCloudを読み込むことができません。.

原因

問題の考えられる原因:

  • リモートアクセスまたは仮想マシン(サーバー接続)が使用されます。例えば、リモートデスクトップコントロール、Windowsリモートデスクトップ、VMwareなどです。.
  • 2枚のグラフィックカードを搭載したノートパソコンが使用され、内蔵グラフィックが選択されています。.
  • Intel HD 3000内蔵グラフィックカードを使用しています。.
  • Windowsプロファイルが破損しています。.

解決

リモートアクセスまたは仮想マシン(サーバー接続)が使用されます

リモートデスクトップ接続

情報: PIX4Dmapper リモートアクセス機能はテストしていないため、公式にはサポートしていません。ただし、rayCloudを動作させることは可能です。そのためには、以下のものが必要です。

- NVIDIA GeForceドライバーR440以降
- Windows 10であること
- グラフィックカードのOpenGLバージョンが3.2以降で

  1. コントロール パネルからグループ ポリシーの編集ツールを開くか、Windows の検索ダイアログ (Windows キー + R を押して、gpedit.msc と入力) を使用します。.
  2. 次の場所を参照してください: ローカル コンピューター ポリシー\コンピューターの構成\管理用テンプレート\Windows コンポーネント\リモート デスクトップ サービス\リモート デスクトップ セッション ホスト\リモート セッション環境。.
  3. 次に、 すべてのリモートデスクトップサービスセッションでハードウェアのデフォルトグラフィックアダプタを使用する
  4. NVIDIAのウェブサイトからAccelerate Windows Remote Desktopをダウンロードしてください。NVIDIAプラットフォームで既に開発者アカウントをお持ちの場合は、それをご利用いただけます。

それでも問題が解決しない場合、また他のプロジェクトでも同様の問題が発生している場合は、リモート コンピューターのグラフィック カード ドライバーを更新し (デバイス マネージャーではなく、グラフィック カードの Web ページから)、PC を再起動してください。ドライバーが OpenGL 3.2 をサポートしていることを確認してください。ドライバーが OpenGL 3.2 をサポートしていることを確認する方法の詳細については、「 グラフィック カードのドライバーが OpenGL 3.2 をサポートしていることを確認する方法」を参照してください

TeamViewer

リモートデスクトップを別の技術で視覚化できるソフトウェアであるTeamViewerを使用してください。リモートデスクトップとローカルデスクトップの両方に同じバージョンをインストールする必要があります。無料ライセンスはWindows Server 2008または2010で使用するとエラーが発生することに注意してください。.

情報: コンピュータに直接アクセスした場合、OpenGL 3.xまたは4.xが使用される可能性がありますが、Windowsリモートデスクトップまたはリモートデスクトップを使用してアクセスした場合は、1.0のみが使用される可能性があります。TeamViewerは元のOpenGLバージョンを保持します。
 

グラフィックカードが2枚搭載されたノートパソコン/デスクトップパソコンを使用し、内蔵カードを選択します。

  1. 機械の種類によって、手順は2つあります。.
    • ノートパソコンの場合:電源設定で専用グラフィックカードが選択されていることを確認してください(ノートパソコンに2枚のグラフィックカード(内蔵または専用)が搭載されている場合、電源設定によってはどちらか一方がアクティブになることがあります)。選択されていない場合は、グラフィックカードメーカーが提供するドライバーではなく、ノートパソコンメーカーから直接グラフィックカードドライバーを入手する必要があるかもしれません。
    • デスクトップPCの場合:専用グラフィックカードがインストールされ、有効になっていることを確認してください。
  2. 専用グラフィックカードのドライバーを更新してください(デバイスマネージャーではなく、グラフィックカードのウェブページから更新してください)。また、 OpenGL 3.2 をサポートしていることを確認してください。ドライバーがOpenGL 3.2をサポートしていることを確認する方法については、 「グラフィックカードのドライバーが OpenGL 3.2 をサポートしていることを確認する方法」を参照してください
  3. それでも問題が解決しない場合は、内蔵グラフィックカードのドライバーを更新してください(デバイスマネージャーではなく、グラフィックカードのウェブページから更新してください)。また、ドライバーがOpenGL 3.2をサポートしていることを確認してください。ドライバーがOpenGL 3.2をサポートしていることを確認する方法の詳細については、 「グラフィックカードのドライバーがOpenGL 3.2をサポートしていることを確認する方法」を参照してください
  4. PCを再起動し、 PIX4Dmapper プロジェクトを開いてください。.
  5. OpenGL 3.2の初期化に失敗した場合でも、BIOSを使用して内蔵グラフィックカードを無効化することができます。こうすることで、デフォルトで専用グラフィックカードが使用されるようになりますが、BIOSで設定を変更する方法を知っておくことが重要です。BIOSで内蔵グラフィックカードを無効にすると、専用グラフィックカードが使用されるようになり、消費電力に影響が出る可能性があります。
  6. Windows 10上で、別のユーザーとしてログインし、ソフトウェアを再度インストールしてください。.

グラフィックカードが1枚搭載されたノートパソコン/デスクトップパソコンを使用します

  1. グラフィックカードのドライバーを更新してください(デバイスマネージャーではなく、グラフィックカードのウェブページから更新してください)。ドライバーがOpenGL 3.2をサポートしていることを確認してください。ドライバーがOpenGL 3.2をサポートしていることを確認する方法の詳細については、 「グラフィックカードのドライバーがOpenGL 3.2をサポートしていることを確認する方法」を参照してください
  2. パソコンを再起動してください。.

内蔵グラフィックカードはIntel HD 3000です。

IntelはIntel HD 3000のドライバーを更新しておらず、このモデルはOpenGL 3.2に対応していません。 別のコンピューターを使用するか、グラフィックカードを交換することを推奨します。

Windowsプロファイルが破損しています

新しいWindowsプロファイルを作成し、その新しいプロファイルに PIX4Dmapper をインストールしてください。.